Question on my SX3

A shotgun forum for basic gun smithing, repair, modifications, and all other detailed shotgun information.

Moderators: waterfowlhunter, don taylor

Question on my SX3

Postby fowlhunter » Thu Feb 16, 2012 11:59 am

When I'm hunting early season and shooting lighter loads it works perfectly every time. But when it gets cold and I'm using hevier steel shot it is a single shot. It wont put the second round in. I tore it down and cleaned it good, I just shot it and on the first three the last shell made almost completely out of the mag. before hanging up. I tappet the tongue and it popped right up and the bolt closed completely. The second three worked flawlessly. Are there any thoughts? I know it's gas powered, but there are a ton of these guns out there that the cold doesnt effect. Any advise would be great.
"It's better to be hated for who you are than be loved for who you're not"
Van Zandt
User avatar
fowlhunter
Forum Moderator
 
Posts: 920
Joined: Tue Jan 17, 2006 2:46 pm
Location: Kansas


Re: Question on my SX3

Postby The Drake » Thu Feb 16, 2012 1:00 pm

What kind of lube and how much are you using........Also when is the last time your magazine tube and more importantly recoil tubes were cleaned.
The Drake
hunter
 
Posts: 729
Joined: Tue Jun 08, 2010 11:21 am
Location: Wisconsin

Re: Question on my SX3

Postby fowlhunter » Thu Feb 16, 2012 1:22 pm

I've used the Winchester and clr. Same result with both. I have cleaned the mag. t
ube but not this time. How do you clean the recoil tube? I could squirt cleaner down it but how do I make sure it all come out?
"It's better to be hated for who you are than be loved for who you're not"
Van Zandt
User avatar
fowlhunter
Forum Moderator
 
Posts: 920
Joined: Tue Jan 17, 2006 2:46 pm
Location: Kansas

Re: Question on my SX3

Postby The Drake » Thu Feb 16, 2012 1:35 pm

Take your recoil pad off, usually 2 phillips screws.........then take off the nut thast holds your stock on...........then take off the nut on the end of the recoil tube, careful that spring is under pressure........clean and re-assemble.......I use 1 drop of oil on the recoil tube........
The Drake
hunter
 
Posts: 729
Joined: Tue Jun 08, 2010 11:21 am
Location: Wisconsin

Re: Question on my SX3

Postby ajmorell » Thu Feb 16, 2012 5:06 pm

When you clean it are you pulling out all of the moving parts (bolt/carrier, trigger assy, etc)? If you haven't done it before it sounds a bit intimidating but is actually very easy to do.
Andy
ajmorell
Forum Moderator
 
Posts: 1661
Joined: Fri Aug 10, 2007 7:40 am
Location: Santa Fe, NM

Re: Question on my SX3

Postby fowlhunter » Thu Feb 16, 2012 5:30 pm

Yes, I actually have taken it apart several times. Just never the part inside the stock.
"It's better to be hated for who you are than be loved for who you're not"
Van Zandt
User avatar
fowlhunter
Forum Moderator
 
Posts: 920
Joined: Tue Jan 17, 2006 2:46 pm
Location: Kansas

Re: Question on my SX3

Postby fowlhunter » Thu Feb 16, 2012 7:54 pm

I just got done completly tearing down cleaning and putting it back together. Thanks for all the help! I'll shoot it tomorrow and let you know.
"It's better to be hated for who you are than be loved for who you're not"
Van Zandt
User avatar
fowlhunter
Forum Moderator
 
Posts: 920
Joined: Tue Jan 17, 2006 2:46 pm
Location: Kansas


Return to Shotgun Repair & Modifications Forum

Who is online

Users browsing this forum: No registered users and 3 guests