outboard help

This is the Utah duck hunting forum where you are invited to communicate with other hunters like yourself.

Moderator: Spiraleyes

outboard help

Postby green head2 » Mon Oct 03, 2005 9:30 pm

I have a 40hp johnson seahorse outboard I just had a tune up done on it It starts fine and runs good up to half throttle When I open it up it stops pushing the boat The motor revs up fine but the boat almost stops Any ideas Thanks
User avatar
green head2
hunter
 
Posts: 412
Joined: Mon May 23, 2005 1:37 pm
Location: centerfield utah


Postby honer » Tue Oct 04, 2005 2:01 pm

looks like you are dealing with a bunch of foot soldiers. sorry we aren't any more help.
User avatar
honer
State Moderator
 
Posts: 321
Joined: Mon Jan 05, 2004 9:29 pm
Location: henefer, utah

Postby phillipstd » Tue Oct 04, 2005 2:21 pm

it's broke :laughing: , you haven't tried taking it back to the guy who did the tuneup and telling him to fix it?? sounds to me like you got weeds in your prop?? realy it sounds like something is messed up in your lower unit
phillipstd
hunter
 
Posts: 189
Joined: Sat Jan 31, 2004 12:04 pm
Location: Rochester WA

Postby green head2 » Tue Oct 04, 2005 3:24 pm

I just wish I knew more about boats I asked this question in the boat & blind section of this site I have had some good responses Now I need to get home And try them out on friday Looks like I may also be a foot soldier again If I cant figure it out Im going to go buy a new boat and mud buddy on the 15th My wife said I better really try to figure it out :smile: Can anyone say lost parts :laughing:
User avatar
green head2
hunter
 
Posts: 412
Joined: Mon May 23, 2005 1:37 pm
Location: centerfield utah


Return to Utah Duck Hunting

Who is online

Users browsing this forum: No registered users and 7 guests