Headlight/electrical problem

Discussion about Trucks, Cars, Motorcycles, & Trailers.

Moderators: fowl_wishes, whisperin' duck, ajmorell, KCDuckMaster

Headlight/electrical problem

Postby mydogearl » Mon Oct 31, 2011 5:56 pm

Im tryin to help my father-in-law find the root of this problem in my sister-in-laws car. I want to see if any of you have any ideas before he takes it somewhere.

03 Hyundai Tiburon. This is rebuilt wreck. Everything worked fine after having everything fixed. The car needed a new battery and when he replaced it, the low beam lights quit working. He replaced the lights and a low beam relay and maybe a fog lamp relay. The fogs will come on when you jiggle the low beam relay but you hear a clicking from the fusebox. All related fuses have been checked.

Thanks in advance
User avatar
mydogearl
hunter
 
Posts: 392
Joined: Sun Apr 01, 2007 8:35 pm
Location: southern OHIO


Re: Headlight/electrical problem

Postby Cujo1 » Mon Oct 31, 2011 7:00 pm

Make sure all the grounds are hooked up to the battery/cable. May have left one loose while changing the battery. Check grounds around the battery, to the fender/radiator support and associated areas around the front. After that get a wiring diagram and start chasing. Good Luck
All turkeys must die!


bighop wrote:Destined to be a child of the system now. Bounced around from house to house, abused, mistreated, earning his way on the streets. There's probably an expensive crack habit and a pair of those hind-leg wheels in his near futre.
User avatar
Cujo1
hunter
 
Posts: 6565
Joined: Wed Jan 12, 2011 4:52 pm
Location: Southern Illinois


Return to Vehicle forum

Who is online

Users browsing this forum: No registered users and 1 guest