99 Ford F 150 EGR Problem

Discussion about Trucks, Cars, Motorcycles, & Trailers.

Moderators: fowl_wishes, whisperin' duck, KCDuckMaster, ajmorell

99 Ford F 150 EGR Problem

Postby Ducs N Bucs 4 Life » Wed Aug 13, 2008 4:19 pm

I've had this problem from day one, Now my extended warranty is out and I have to pay to fix this. Anyone out here ever had this problem.

Ducs and Bucs
Ducs N Bucs 4 Life
Newb
 
Posts: 2
Joined: Thu Aug 07, 2008 11:02 am


Postby fowl_wishes » Wed Aug 13, 2008 4:43 pm

Define EGR problems.
Shoot'em close. Less to pick.

They might get my guns, but they'll get the bullets first !
User avatar
fowl_wishes
Forum & State Moderator
 
Posts: 2640
Joined: Thu Feb 15, 2007 8:46 pm
Location: Eastern NC

Postby KCDuckMaster » Wed Aug 13, 2008 6:38 pm

Ya, that description is a little, vague.

What have you done so far?

If I had to take a guess, im gonna say you are getting codes for inadequate exhaust gas circulation. So I would recommend checking your DPFE sensor
If they weren’t meant to be eaten, then why are they made of meat?
KCDuckMaster
Forum & State Moderator
 
Posts: 370
Joined: Wed Feb 16, 2005 6:59 pm
Location: Right in the Middle

Postby dirtysouthassassin » Fri Nov 07, 2008 9:48 pm

You have carbon build up in your EGR valve. I went overboard to make sure I got it real good and clean but I unhooked the EGR valve and throttle body and everything else that needed unhooking, Be sure and get the 3 gaskets before starting. And DON"T over tighten any bolts. I broke one in the aluminum block, and it sucked getting out. But use carburetor cleaner to clean it out. Hook battery cables back up and light should go off and stay off. It should take 1-2hour if you clean it as good as I did. I have to clean mine about every 100,000 miles.
Migration Stops Here!
User avatar
dirtysouthassassin
hunter
 
Posts: 75
Joined: Mon Sep 17, 2007 10:10 am
Location: Savannah, TN

Postby Higgins » Sat Nov 08, 2008 8:56 pm

half the time it is the sensor itself...i have had this problem on ford cars as well as trucks...check the sensor first
Higgins
hunter
 
Posts: 22
Joined: Mon Aug 04, 2008 7:21 pm


Return to Vehicle forum

Who is online

Users browsing this forum: No registered users and 2 guests