SBE 2 double feeding

A shotgun forum for basic gun smithing, repair, modifications, and all other detailed shotgun information.

Moderators: waterfowlhunter, don taylor

SBE 2 double feeding

Postby garza7585 » Tue Nov 06, 2012 3:41 pm

Hey guys im having an issue with my somewhat new SBE 2.

In the last 2 weeks i've had 2 double feeds from my gun. I'll shoot and the shell ejects and then the last two shells feed. One will be out in the lever and about a half inch from the other one would be poking out of the magazine as well keeping the first one from feeding.

Its happened with a clean gun and with a dirty gun. The last time it malfunctioned, I cleaned it I pulled the plug and mag spring to clean it as well.

Any other ideas of what might be the issue?
garza7585
hunter
 
Posts: 133
Joined: Sun Oct 23, 2011 6:21 pm


Re: SBE 2 double feeding

Postby TROB » Wed Nov 07, 2012 6:29 pm

i had the same problem a lot last season. It started doing it again this year and I swapped the mag spring for a wolff +25% spring. It is a lot better, but it has had 1 double feed with the new spring.

You're saying it launches 2 shells and the shells get stuck in a straight line at the bottom of the receiver, right? That's what mine was doing.
Idaho...
User avatar
TROB
hunter
 
Posts: 376
Joined: Sat Jan 02, 2010 12:34 pm
Location: Southern Idaho

Re: SBE 2 double feeding

Postby garza7585 » Thu Nov 08, 2012 6:59 am

Yep... Thats what mine is doing. It has done it twice.

So far I took the mag spring out and cleaned the tube and spring and I stretched it out a bit hopin it would add more tension and force.

Ive only shot it twice since and its been ok.

Another gentleman told me it could be the cartridge latch and/or latch spring needs to be replaced or readjusted.



Sent from my SGH-T989 using Tapatalk 2
garza7585
hunter
 
Posts: 133
Joined: Sun Oct 23, 2011 6:21 pm

Re: SBE 2 double feeding

Postby toolmaker » Thu Nov 08, 2012 8:16 am

id make sure the trigger group is cleaned very well....get compressed air and blow it out with a bunch of cleaner soaking in the group...

it doesnt sound like the mag spring should be at fault... there should be a shell catch that is forced up...make sure its spring is clean and there is nothing to hinder its quick recovery.....

once the shells base moves past the catch it should be trying to close...and should rub on the plastic shells length as it goes by and is forced over to prevent the second shell from followign the first....maybe there is a machining burr hanging up the free movement of the catch and its spring


the tool
favorite quote: We constantly dont do things this way
User avatar
toolmaker
hunter
 
Posts: 2934
Joined: Tue Aug 31, 2010 6:19 am
Location: only been to Cromwell once

Re: SBE 2 double feeding

Postby TROB » Thu Nov 08, 2012 9:07 am

If mine keeps doing it, I'm going to replace the latch and latch spring. The new extra heavy mag spring seems to have helped a ton. We'll see.

I called benelli about it and they said it was a 2 month turnaround....during duck season? Yea right, I'll fix it myself. :lol3:
Idaho...
User avatar
TROB
hunter
 
Posts: 376
Joined: Sat Jan 02, 2010 12:34 pm
Location: Southern Idaho

Re: SBE 2 double feeding

Postby garza7585 » Thu Nov 08, 2012 1:24 pm

I haven't cleaned my trigger group yet and i've probably ran 450 rounds through the gun so far. It was on my list of things to do. I think i'll do it tonight.
garza7585
hunter
 
Posts: 133
Joined: Sun Oct 23, 2011 6:21 pm

Re: SBE 2 double feeding

Postby Park Duck » Thu Nov 08, 2012 3:07 pm

Latch/latch spring :thumbsup:
User avatar
Park Duck
hunter
 
Posts: 613
Joined: Wed Aug 24, 2005 10:52 am
Location: Natchez Ms

Re: SBE 2 double feeding

Postby toolmaker » Thu Nov 08, 2012 4:55 pm

garza7585 wrote:I haven't cleaned my trigger group yet and i've probably ran 450 rounds through the gun so far. It was on my list of things to do. I think i'll do it tonight.



if you have never pulled out the trigger group and looked at it. you will realize when you do, all the effect its operation has on the cycling of the action!!

when you go to install it after you clean it...you need to compress that one part that is spring loaded on the inside of the action to allow the carrier on the trigger group to get by....then the trigger groups goes in easily ....

i dont know the name of that part that is forced inward by a spring....but you need to close that as you install the trigger group....at least until the carrier can get in far enough to hold that part by itself.

good luck

the tool
favorite quote: We constantly dont do things this way
User avatar
toolmaker
hunter
 
Posts: 2934
Joined: Tue Aug 31, 2010 6:19 am
Location: only been to Cromwell once

Re: SBE 2 double feeding

Postby toolmaker » Thu Nov 08, 2012 5:14 pm

Image

Image

part # 17 on the barrel diagram is the latch you want to hold in while you install the trigger group

you want to press in the back side against the spring#16.

you can access through the bottom of the reciever

the tool
favorite quote: We constantly dont do things this way
User avatar
toolmaker
hunter
 
Posts: 2934
Joined: Tue Aug 31, 2010 6:19 am
Location: only been to Cromwell once

Re: SBE 2 double feeding

Postby garza7585 » Thu Nov 08, 2012 6:18 pm

Just pulled trigger group and sprayed it with some CLP and blew it out with my air compressor. Got it as dry as possible and wiped any excess.

Hope this solves any issues.

Sent from my SGH-T989 using Tapatalk 2
garza7585
hunter
 
Posts: 133
Joined: Sun Oct 23, 2011 6:21 pm

Re: SBE 2 double feeding

Postby toolmaker » Thu Nov 08, 2012 6:34 pm

garza7585 wrote:Just pulled trigger group and sprayed it with some CLP and blew it out with my air compressor. Got it as dry as possible and wiped any excess.

Hope this solves any issues.

Sent from my SGH-T989 using Tapatalk 2



how dirty was it???

look bad?

mine always looks absolutely filthy!!! all kinds of grit and weeds, and dust

the tool
favorite quote: We constantly dont do things this way
User avatar
toolmaker
hunter
 
Posts: 2934
Joined: Tue Aug 31, 2010 6:19 am
Location: only been to Cromwell once

Re: SBE 2 double feeding

Postby garza7585 » Thu Nov 08, 2012 9:29 pm

Not super bad... The area around the hammer and any moving parts there was a bit of black coming out...

Sent from my SGH-T989 using Tapatalk 2
garza7585
hunter
 
Posts: 133
Joined: Sun Oct 23, 2011 6:21 pm

Re: SBE 2 double feeding

Postby rerhardt » Tue Nov 13, 2012 6:44 pm

call benelli and tell them you need a new shell latch, ill bet the farm this fixes the issue
rerhardt
hunter
 
Posts: 72
Joined: Mon Jan 16, 2012 9:13 pm

Re: SBE 2 double feeding

Postby wanapasaki » Tue Nov 13, 2012 6:50 pm

Just sell it and get a beretta extrema. I hear alot of benelli shooters with this problem. Im not big on inertia guns, because it was been improved with gas. Anyways my other advice would be to take it to the retailer you got it from and let them know you want them to fix the issue. I buy guns at 2nd amendments where I live and they warranty all of their gear and if they cannot fix it, it gets sent back to the manufacturers gunsmiths. anyways best of luck, hope you get this resolved quickly. Always keep a pump action with you when you shoot any autoloaders :beer:
Give a man a duck... Feed him for a day... Teach him to fowl hunt... Feed him for a lifetime...Teach him in your spot... Learn to hunt a different spot....
User avatar
wanapasaki
hunter
 
Posts: 2504
Joined: Wed Jun 06, 2012 6:45 am
Location: Tehachapi, CA

Re: SBE 2 double feeding

Postby garza7585 » Thu Nov 15, 2012 12:25 am

I've done quite a bit of shooting the last couple times out and so far so good.

Sent from my SGH-T989 using Tapatalk 2
garza7585
hunter
 
Posts: 133
Joined: Sun Oct 23, 2011 6:21 pm


Return to Shotgun Repair & Modifications Forum

Who is online

Users browsing this forum: No registered users and 3 guests