Duck Hunting Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Just got a new SBE II from bass pro and am having some problems getting the barrel onto the stock. Is it normally extremely difficult to get the barrel on or do I have a problem with the gun. The only way I can imagine getting it on is to hammer it with a rubber mallet. I didnt think it would be this difficult to get the barrel to fit. What options do I have or what should I do?

This is as far as it will go. It will NOT slip in.
 

·
Registered
Joined
·
129 Posts
Pull the bolt back. The reciever should slip into place. If not something is definately wrong.

BPShunter
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
I took the bolt out and it still will not go in.

There is nothing that I can find like a burr or anything stopping it from going in. I really dont know what the problem is. It looks like it should go in but it just isnt. Maybe I will take it by a gun smith tomorrow and let them look at it.

Anyone else have any ideas?
 

·
Registered
Joined
·
608 Posts
I agree with duck...check and see for burrs...i've read other posts in other forums and some guys were having the same problem...i also have a SBE2 bought it in Dec and had alil trouble with it,but it wore in after a few times and now fits like a glove..just watch your fingers and i would'nt bang it in with any thing...slide the firing pin housing out and see if it goes in...you might just have a aliament problem your not seeing....Honkers41
 

·
Registered
Joined
·
164 Posts
I would take the gun back to Bass Pro to have them take a look at it.
I would not shoot it like this!.... If they give you any problem with a return or replacement ask them what liability they may face if a problem occurs?
I shoot an SBE - and have had no problems with the gun - I would not take your gun to the field for my own safety nor would I expose others to any problem that may occur as a result of a malfunction.
Do the right thing for yourself, your friends and the manufacturer.
This is NOT a cosmetic problem but rather a disaster in the making.
Good luck with a fix to the problem.
 

·
Registered
Joined
·
405 Posts
I had the same thing with my new SBE II. It appears to be only the camo ones that have the problem. Here is how I fixed mine. There seems to be some camo over run on and in the grooves. I took a nife and scraped the extra camo off of those grooves and puff, the problem fixed. I would only take off enough for a snug fit. It is always better for a tighter than looser fit. If you know what I mean.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #13 ·
Thanks for the help but it fits now. I had the camo scrapped off and it was still not going in. I figured that was the problem but it was still not fitting. I took the gun to gander mnt and their gun smith said he would look at it for me. He got it together but then could not really get it apart so took it in the back and did some "artificial wear" on that part of the gun and now it snaps together. Still takes a little force but it goes together now. Thanks for all the help.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top